Skip to content

Vulnerabilidades en PostgreSQL

Publicado por Sergio Hernando el 18 febrero 2005

Acabo de leer en Security Focus dos artículos que hablan de sendas vulnerabilidades detectadas en el gestor de base de datos PostgreSQL.

Es poco frecuente que se detecten vulnerabilidades en este gestor, principalmente por dos motivos:

  • Es un gestor seguro y bien programado
  • Tiene una tasa de usuarios menor que otras soluciones del segmento, lo que hace que se testee y pruebe menos, y por tanto, aparezcan menos problemas y vulnerabilidades

Aún así, en todas partes cuecen habas. PostgreSQL LOAD Extension Local Privilege Escalation Vulnerability es una vulnerabilidad que afecta a la extensión LOAD. Un fallo de la aplicación a la hora de restringir funcionalidad crítica a los usuarios con privilegios puede provocar una escalada de los mismos a nivel local. Esto podría permitir a un atacante la ejecución de código arbitrario.

PostgreSQL Multiple Remote Vulnerabilities es un conjunto de vulnerabilidades remotas debidas a errores de diseño y gestión incorrecta del buffer.

La primera vulnerabilidad de este grupo es un fallo de la aplicación en la gestión de permisos y su obligatoriedad. El segundo problema es un buffer overflow. Adicionalmente hay una vulnerabilidad no documentada existente en contrib/intagg. Un atacante podría ejecutar código arbitrario para ejecutar funciones sin que se le requieran los pertinentes permisos.

Para los usuarios de PostgreSQL recomiendo lógicamente visitas periódicas a la web del producto para obtener actualizaciones e información adicional sobre ambos problemas, así como permanecer atentos a las actualizaciones del bugtraq ya que una de las fallas sigue sin esclarecer y la explotación de la misma no está cuantificada en riesgo ni probabilidades a día de hoy, con lo que todas las precauciones en los sistemas que operan con este gestor de base de datos son pocas.

Un saludo.

Be Sociable, Share!

Categoría/s → Seguridad

Comentarios cerrados.